quarta-feira, maio 25, 2005

Função SE Matricial com Intervalo de dados

"Basta sermos simples para sermos ricos em nossos atos!" (E.S.P.)
----------


=SE((B1>=31)*(B1<=180);0,1;SE((B1>=181)*(B1<=360);0,12;SE(B1>=361;0,15)))

Mas antes de finalizar, use "CTRL + SHIFT + ENTER", pois trata-se de função matricial, ficando assim:

{=SE((B1>=31)*(B1<=180);0,1;SE((B1>=181)*(B1<=360);0,12;SE(B1>=361;0,15)))}

----------
Maiores esclarecimentos, acesse o link que está no título deste post !

5 comentários:

Anônimo disse...

Acho que de ser facil, só que eu esqueci!!!
Tenho um valor e devo classifica-lo de A,B ou C, como fazer?
Ex:
Valores Até 80 = A
Valores de 81 até 95 = B
Valores de 96 até 100 = C

Grato

Elias Branco
eliasdpkprudente@terra.com.br

Eneias disse...

Considerando os valores em "A1", use a seguinte função:

=SE(A1<=80;"A";SE(A1<=95;"B";SE(A1<=100;"C";"->Erro")))

Matheus rodrigues disse...

eu preciso classificar diferente,
Um valor de
Valor até 100= Muito Arenoso
Valor de 100 até 150= Arenoso
Valor de 151 até 250= Médio Arenoso
Valor de 251 até 350= Médio Argiloso
Valor de 351 até 600= Argiloso
Valores maiores que 600= Muito Argiloso

Grato

Matheus
MatheusVr92@gmail.com

Matheus rodrigues disse...

eu preciso classificar diferente,
Um valor de
Valor até 100= Muito Arenoso
Valor de 100 até 150= Arenoso
Valor de 151 até 250= Médio Arenoso
Valor de 251 até 350= Médio Argiloso
Valor de 351 até 600= Argiloso
Valores maiores que 600= Muito Argiloso

Grato

Matheus
MatheusVr92@gmail.com

Matheus rodrigues disse...

Consegui sozinho obrigado.

Ficou assim

=SE((B2<=100);"Muito_Arenoso";SE((B2>100)*(B2<=150);"Arenoso";SE((B2>150)*(B2<=250);"Médio_Arenoso";SE((B2>250)*(B2<=350);"Médio_Argiloso";SE((B2>350)*(B2<=600);"Argiloso";"Muito_Argiloso")))))